2.9.1007 out

Latests news, download links and announcements about Xt7-Player.

2.9.1007 out

Postby kokoko3k on Fri Sep 02, 2011 10:45 am

gambas 2.99.2 is strictly required.

Changelog:
Code: Select all
CHANGE: Exit from fullscreen at the end of the media or stop
FIX: Prevent an mplayer window to popup when updating library/playlist items (regression)
FIX: ExportFile names are now random
FIX: Updated Italian translation
NEW: Panscan (Zoom) button (roll mouse wheel over it)
FIX: Fixed some youtube issues when using 'next' button
NEW: Youtube search: "More results" arrow at the end of any search result
FIX: Sometimes codec list didn't show up
FIX: Possible runtime error when using vmeters
FIX: Don't throw an error if trying to disable kwin effects without kwin
FIX: Updated some symbols to be compatible with new gambas release
CHANGE: Made a version check; gambas 2.99.2 is strictly required.
NEW: several dbus properties exported at: org.gambas.xt7.player -> xt7/org.gambas.xt7.player.dbusproperties/
CHANGE: FileSize is expressed in Kbytes now (library rebuild needed to not break sorting by size)
FIX: Clear zoom level now restores 1:1 zoom and not 10:1
FIX: Changed youtube backend to rely on youtube-dl python script (now required)
CHANGE: Youtube stream download now works only when using wget or aria2c download manager

http://kde-apps.org/content/show.php?content=140892
.
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: 2.9.1007 out

Postby symbianflo on Sun Sep 04, 2011 11:43 am

Code: Select all
xt7-player 2.9.1007
Usage: xt7-player.gambas [Options] Mediafile
Options:
-append (add a media to the playlist)


global.init.76: #11: Unknown symbol 'DefaultDir' in class 'Settings'
0: global.init.76
1: zzzFake.Start.15
2: StartClass.main.4


And dies :( after a pop up with:

Code: Select all
This application has raised an unexpected
error and must abort.

[11] Unknown symbol 'DefaultDir' in class 'Settings'.
global.init.76


:(
symbianflo
 
Posts: 123
Joined: Mon May 25, 2009 12:50 pm

Re: 2.9.1007 out

Postby kokoko3k on Sun Sep 04, 2011 6:52 pm

Symbianflo, that error means you're not running the very latest gambas revision.
Starting from 2.9.1007, you need at least Gambas>=2.99.2
Unfortunately several symbols are changed (that's the drawback on using alpha/beta versions :) ), one of them is "DefaultDir", which is giving you the error you are facing.
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: 2.9.1007 out

Postby symbianflo on Sun Sep 04, 2011 8:51 pm

ok then I think will be available only for mandriva 2011.0, and no more for 2010.2 i can not rebuild again a new gambas porting due to the lack of time :(
Thx for help.
symbianflo
 
Posts: 123
Joined: Mon May 25, 2009 12:50 pm

Re: 2.9.1007 out

Postby kokoko3k on Mon Sep 05, 2011 12:09 am

Understood, unfortunately it does not depends on me.
Thank you for your efforts, as usual!
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: 2.9.1007 out

Postby symbianflo on Sun Sep 18, 2011 11:07 am

I'll keep packaging for mdv but only for 2011.0
I have to ask you a favor , can you post when you build it on new gambas3 -%_version ?
Thx

PS:
OMFG this player of your it is better and better , you got it right with youtube-dl soooopaaaa
keep in touch m8.
ciao bell
symbianflo
 
Posts: 123
Joined: Mon May 25, 2009 12:50 pm

Re: 2.9.1007 out

Postby kokoko3k on Sun Sep 18, 2011 12:08 pm

symbianflo wrote:I'll keep packaging for mdv but only for 2011.0
I have to ask you a favor , can you post when you build it on new gambas3 -%_version ?
Thx


No need to ask, I did it in the changelog:
CHANGE: Made a version check; gambas 2.99.2 is strictly required.

yet, maybe the version check didn't work as expected.

Thank you for your packages, as usual!
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: 2.9.1007 out

Postby symbianflo on Sun Sep 18, 2011 2:10 pm

kokoko3k wrote:yet, maybe the version check didn't work as expected.



might be ??? :lol:
doesn't matter, just for me pls, write 2
words about gambas-version in the new rel post .
please?

PS:
love xt7, OREFICE 4 PRESIDENT
symbianflo
 
Posts: 123
Joined: Mon May 25, 2009 12:50 pm

Re: 2.9.1007 out

Postby kokoko3k on Sun Sep 18, 2011 7:28 pm

Even if i didn't understood well what you mean, i bolded the changelog entry in the first post about the required version and if needed i'll write in next posts too.
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm


Return to News and downloads

Who is online

Users browsing this forum: No registered users and 1 guest

cron

SourceForge.net Logo