0.9.262 out

Latests news, download links and announcements about Xt7-Player.

0.9.262 out

Postby kokoko3k on Mon Nov 15, 2010 11:46 am

- NEW: Initial youtube support (youtube tab), choose between 360p,720p,1080p in network preferences
- NEW: Added -cache-min option in network preference (very useful for youtube streams)
- NEW: Added -cache-seek-min option in network preference( very useful for youtube streams)
- CHANGE: added gb.web dependancy
- NEW: Added -prefer-ipv4 option in network preference
- NEW: stream address in log window
- CHANGE: max cache value raised to 100MB
- FIX: explicitely ignore any config file (-noconfig all)
- FIX: update shoutcast gave a runtime error
- FIX: disable all video filters for vaapi
- CHANGE: reorganized window to best fit wide screens and netbooks
(vaapi is not natively supported, but at least it will work now if you specify it as a custom video driver).

Some notes about youtube support:
I strongly reccommend you:
-to use a local dns instead of a faraway one (see: avoid opendns) for seeking to work in most of the cases.
-have a large cache for network streams (even 30MB), it will allows you to buffer the stream when you pause.
-have start playback after filling ## set to a very low value to allow the stream to start early
-have minimumseek cache size ## set to a very low value to seek faster
-prefer-ipv4 set to speedup things if you have an ipv4 network.

Hint: Downloading youtube videos is not currently supported yet, but as soon as you are playing one, you can just go to the log window and grab the url.

Image


http://kde-apps.org/content/show.php/Xt ... tent=86197
Enjoy!
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: 0.9.262 out

Postby ikisham on Thu Nov 18, 2010 12:14 pm

Hi, maybe only downloading is not supported but here, with the default settings, Xt7-player downloads the video to my home folder before playing it.
ikisham
 
Posts: 9
Joined: Tue Nov 16, 2010 3:37 pm

Re: 0.9.262 out

Postby kokoko3k on Thu Nov 18, 2010 5:34 pm

Are you talking about youtube tab? I just checked and it doesn't happen here.
Can you be more specific and provide logs/ls output and so on?
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: 0.9.262 out

Postby ikisham on Sun Nov 28, 2010 1:13 pm

Hello. Sorry for the delay.
Yes, I'm talking about the YT tab.

If I select a video and click the play button, xt7 thinks a bit and then shows "Stopped" in the status bar. Below is an example output from the terminal:
Code: Select all
-vf-pre scale  -ass  -ass-force-style Alignment=2,FontName="Bitstream Vera Sans",FontSize=18,Bold=1,Italic=,outline=1,OutlineColour=H00000000,MarginV=10,PrimaryColour=H00FFFFFF,shadow=2,BackColour=H7F000000 -sub-fuzziness 0  -subfont-osd-scale 4 -subfont-text-scale 4 -subpos 10 -prefer-ipv4   -cdrom-device "Please, choose"  -vf-add eq2,hue,screenshot,scale 
renice: 3799: 3509: prioridade antiga = 0; prioridade nova = 0
getpriority: Processo inexistente

*note: "Processo inexistente" mean "Inexistent process".

So for me to play it I have to double-click the selected video, then xt7 downloads the video to my ~ folder and then plays it. I did this with the same video from the above example and here's the terminal output:
Code: Select all
-vf-pre scale  -ass  -ass-force-style Alignment=2,FontName="Bitstream Vera Sans",FontSize=18,Bold=1,Italic=,outline=1,OutlineColour=H00000000,MarginV=10,PrimaryColour=H00FFFFFF,shadow=2,BackColour=H7F000000 -sub-fuzziness 0  -subfont-osd-scale 4 -subfont-text-scale 4 -subpos 10 -prefer-ipv4   -cdrom-device "Please, choose"  -vf-add eq2,hue,screenshot,scale 
renice: 3820: 3509: prioridade antiga = 0; prioridade nova = 0
setpriority: Permissão negada

*note: "Permissão negada" means "Permission denied".

The log for it:
Stream: P7umL2HKfYCg0eexMU7itotTAgOM=&eurl=&el=&ps=&asv=&fmt=18
Commandline:
LC_ALL=C mplayer -identify -slave -wid 33556103 -noconfig all -mouse-movements -vf-pre scale -ass -ass-force-style Alignment=2,FontName="Bitstream Vera Sans",FontSize=18,Bold=1,Italic=,outline=1,OutlineColour=H00000000,MarginV=10,PrimaryColour=H00FFFFFF,shadow=2,BackColour=H7F000000 -sub-fuzziness 0 -subfont-osd-scale 4 -subfont-text-scale 4 -subpos 10 -prefer-ipv4 -cdrom-device "Please, choose" -vf-add eq2,hue,screenshot,scale -vo xv,gl,gl2,x11,null, -ao oss:/dev/dsp:/dev/mixer:pcm,alsa,arts,esd:localhost,jack,pulse::,null, -alang "en,eng" -slang "en,eng" -sub '_NuLl_nUlL' -input conf=/tmp/FakeInput.conf:file=/home/temp/.config/gambas/Xt7-Player/.InputPipes/Xt7Input-30053 "http://www.youtube.com/get_video?video_id=xrMTjM0YRJs&t=vjVQa1PpcFNwXZSP7umL2HKfYCg0eexMU7itotTAgOM=&eurl=&el=&ps=&asv=&fmt=18"

MPlayer SVN-r31918 (C) 2000-2010 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Playing http://www.youtube.com/get_video?video_ ... sv=&fmt=18.
Resolving www.youtube.com for AF_INET...
Connecting to server www.youtube.com[72.14.253.91]: 80...
Resolving v11.lscache8.c.youtube.com for AF_INET...
Connecting to server v11.lscache8.c.youtube.com[173.194.18.168]: 80...
Resolving v3.cache7.c.youtube.com for AF_INET...
Connecting to server v3.cache7.c.youtube.com[74.125.211.210]: 80...
Cache size set to 320 KBytes
libavformat file format detected.
ID_VIDEO_ID=0
[lavf] stream 0: video (h264), -vid 0
ID_AUDIO_ID=0
[lavf] stream 1: audio (aac), -aid 0, -alang und
VIDEO: [H264] 400x226 24bpp 59.750 fps 409.5 kbps (50.0 kbyte/s)
Clip info:
major_brand: mp42
ID_CLIP_INFO_NAME0=major_brand
ID_CLIP_INFO_VALUE0=mp42
minor_version: 0
ID_CLIP_INFO_NAME1=minor_version
ID_CLIP_INFO_VALUE1=0
compatible_brands: isommp42
ID_CLIP_INFO_NAME2=compatible_brands
ID_CLIP_INFO_VALUE2=isommp42
ID_CLIP_INFO_N=3
File not found: '_NuLl_nUlL'
Failed to open _NuLl_nUlL.
File not found: '_NuLl_nUlL'
Failed to open _NuLl_nUlL.
[ass] ass_read_file(_NuLl_nUlL): fopen failed
Cannot load subtitles: _NuLl_nUlL
ID_FILENAME=http://www.youtube.com/get_video?video_id=xrMTjM0YRJs&t=vjVQa1PpcFNwXZSP7umL2HKfYCg0eexMU7itotTAgOM=&eurl=&el=&ps=&asv=&fmt=18
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=H264
ID_VIDEO_BITRATE=409512
ID_VIDEO_WIDTH=400
ID_VIDEO_HEIGHT=226
ID_VIDEO_FPS=59.750
ID_VIDEO_ASPECT=1.7699
ID_AUDIO_FORMAT=MP4A
ID_AUDIO_BITRATE=86368
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
ID_START_TIME=0.00
ID_LENGTH=73.89
ID_SEEKABLE=1
ID_CHAPTERS=0
[ass] auto-open
Opening video filter: [scale]
Opening video filter: [screenshot]
Opening video filter: [hue]
Opening video filter: [eq2]
Opening video filter: [scale]
[ass] Init
[ass] Updating font cache
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
ID_VIDEO_CODEC=ffh264
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
AUDIO: 44100 Hz, 2 ch, s16le, 86.4 kbit/6.12% (ratio: 10796->176400)
ID_AUDIO_BITRATE=86368
ID_AUDIO_RATE=44100
ID_AUDIO_NCH=2
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
[AO OSS] audio_setup: Can't open mixer device /dev/mixer: No such file or directory
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
Failed to initialize audio driver 'oss:/dev/dsp:/dev/mixer:pcm'
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
ID_AUDIO_CODEC=faad
Starting playback...
Movie-Aspect is 1.77:1 - prescaling to correct movie aspect.
ID_VIDEO_ASPECT=1.7699
[swscaler @ 0x8b5e900]using unscaled yuv420p -> yuv420p special converter
A: 0.1 V: 0.0 A-V: 0.089 ct: 0.000 0/ 0 ??% ??% ??,?% 0 0 0% 

Regards.
ikisham
 
Posts: 9
Joined: Tue Nov 16, 2010 3:37 pm

Re: 0.9.262 out

Postby kokoko3k on Mon Nov 29, 2010 3:39 pm

I can solve the issue when you select video file and then click the play button, that gives you the error "getpriority: Processo inexistente".
The other issue (setpriority: Permissão negada) is triggered when you leave the renice value to the standard value and you have not root privileges. To avoid it either run xt7-player via sudo or set renice value >1.
Both have nothing to do with the fact that you have that video in your home folder, what xt7-player does is just launching mplayer to open a network (http) stream, so if you have it in your home folder, maybe is mplayer itself which is doing that,
anyway this never happened to me and still i can't make it happens, nor i see something important in the log you posted.
It's very strange.

Please can you:
-view a youtube video
-while you're watching it, do from a shell:
# cd <the folder containing the video you say xt7 have downloaded>
# date ; ls -la

and paste the results?

Thanks
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: 0.9.262 out

Postby ikisham on Thu Dec 09, 2010 6:12 pm

Sorry, I missed your response. I was going to test it but now I'll install the latest version and test on it.
ikisham
 
Posts: 9
Joined: Tue Nov 16, 2010 3:37 pm

Re: 0.9.262 out

Postby kokoko3k on Thu Dec 09, 2010 6:22 pm

Just uploaded
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: 0.9.262 out

Postby symbianflo on Fri Dec 10, 2010 1:01 pm

Just build it :lol: for mdv...
great work m8.

Suggest use this mplayer :
Code: Select all
rpm -q -i mplayer
Name        : mplayer                      Relocations: (not relocatable)
Version     : 1.0                               Vendor: Penguin Liberation Front
Release     : 1.rc4.0.r32675.1plf2010.1     Build Date: lun 06 dic 2010 20:39:00 CET
Install Date: mer 08 dic 2010 16:37:21 CET      Build Host: delta.onse.fi
Group       : Video                         Source RPM: mplayer-1.0-1.rc4.0.r32675.1plf2010.1.src.rpm
Size        : 11538265                         License: GPLv2
Signature   : DSA/SHA1, lun 06 dic 2010 20:47:00 CET, Key ID 53dbb2a2caba22ae
Packager    : Anssi Hannula <xxxxxxx@zarb.org>
URL         : http://www.mplayerhq.hu
Summary     : Movie player for linux




PS:
still here, miss me ? ghghghghghgh
symbianflo
 
Posts: 123
Joined: Mon May 25, 2009 12:50 pm

Re: 0.9.262 out

Postby kokoko3k on Fri Dec 10, 2010 2:47 pm

symbianflo wrote:Just build it :lol: for mdv...
great work m8.

Run for 0.9.272 then :)
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: 0.9.262 out

Postby symbianflo on Sat Dec 11, 2010 10:36 am

9.273 you mean ghghghgh np WIP :lol:
symbianflo
 
Posts: 123
Joined: Mon May 25, 2009 12:50 pm


Return to News and downloads

Who is online

Users browsing this forum: No registered users and 1 guest

cron

SourceForge.net Logo