[FIXED] Size

Improve Xt7-Player by reporting bugs.
Be kind, and try to find under which conditions we can reproduce the bug.

[FIXED] Size

Postby geaplanet on Sun May 27, 2012 10:27 am

Hi!

I have a little problem with the video size.
I'm using X11 driver and all videos are playing in a small size, even in fullscreen (with an enormouse black frame around).

If I run "mplayer myvideo.avi", I get the same small video. But if I run "mplayer -zoom myvideo.avi" I can watch videos perfectly even in fullscreen.

Is there -zoom option in any place of XT7 configuration?


Thanks in advance.
Last edited by geaplanet on Tue May 29, 2012 3:38 am, edited 2 times in total.
geaplanet
 
Posts: 5
Joined: Tue May 15, 2012 10:24 pm

Re: Size

Postby kokoko3k on Sun May 27, 2012 12:11 pm

You are right, there is no -zoom option available; i didn't make one because sotware scaling is heavy in term of cpu work.
You can add it manually to xt7 by typing "-zoom" into:
General options -> misc -> additional options
After that Hit USE and save
if you wish, and all should be fine.
Are you sure you are unable to use any other video drivers (xv, gl, gl2) ?

-edit
I'm not 100% sure -zoom option only affects that video drivers that doesn't support hw scaling, but if it is that so, i'll add as an option or, if vdpau and vaapi are ok with that, even as default.
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: Size

Postby geaplanet on Sun May 27, 2012 3:52 pm

Perfect.

I can't use other drivers, I'm in a Virtualbox Machine and if I choose other drivers I get only audio working.

But in my old machines normally work XV too.

X11 is slow, but sometimes is the only posible option. Anyway, if the machine is really old -zoom option doen't affect to the CPU unless you resize the video in a big window or fullscreen.
I like this solution in extra parameters, or even put it in a checkbox option. And if you put by default I don't think it could be a problem either.
geaplanet
 
Posts: 5
Joined: Tue May 15, 2012 10:24 pm

Re: Size

Postby kokoko3k on Sun May 27, 2012 5:43 pm

Fine, i'll do some test and see what is be the best option.

Meantime, you may try to enable 3d into virtualbox and install vboxtools, that way maybe gl output will be available.
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: Size

Postby geaplanet on Sun May 27, 2012 6:09 pm

I have a good 3d card, but with gl output performance is worse than X11. After google for a while I found this:
http://www.mplayerhq.hu/DOCS/HTML/en/opengl.html
and this
http://forums.gentoo.org/viewtopic-t-88 ... art-0.html

Appears opengl output is not very good.
geaplanet
 
Posts: 5
Joined: Tue May 15, 2012 10:24 pm

Re: Size

Postby kokoko3k on Sun May 27, 2012 11:42 pm

Gl performance is worse only if you don't have an accelerated gl rendering,in that case all the work is done by cpu, and this can happens if virtualbox isn't properly configured.
If you manage to get virtualbox to accelerate 3d rendering, opengl output will be WAY better than x11.

So i strongly suggest you to install virtualbox Guest Additions and enable 3d acceleration.

http://www.virtualbox.org/manual/ch04.html#guestadd-3d
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: Size

Postby kokoko3k on Mon May 28, 2012 3:07 pm

Grab the latest git commit, i've added the zoom option under General options -> video.
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: Size

Postby geaplanet on Tue May 29, 2012 3:37 am

It works ok, thanks.
geaplanet
 
Posts: 5
Joined: Tue May 15, 2012 10:24 pm


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron

SourceForge.net Logo