[FIXED] Xt7-player does not playl mts video format

Improve Xt7-Player by reporting bugs.
Be kind, and try to find under which conditions we can reproduce the bug.

[FIXED] Xt7-player does not playl mts video format

Postby eloaders on Thu Dec 29, 2011 2:01 pm

Code: Select all
Commandline:
LC_ALL=C mplayer -identify -slave  -wid 54526430 -noconfig all         -vf-pre scale  -alang "en,eng"  -slang "en,eng"  -ass  -ass-force-style FontName="Bitstream Vera Sans",FontSize=18,Bold=1,Italic=Alignment=2,outline=1,OutlineColour=H00000000,MarginV=10,PrimaryColour=H00FFFFFF,shadow=2,BackColour=H7F000000 -sub-fuzziness 0  -subfont-osd-scale 4 -subfont-text-scale 4 -subpos 10 -softvol -prefer-ipv4 -dvbin card=1 -dvbin timeout=10  -cdrom-device "Please, choose"  -vf-add eq2,hue,screenshot,scale    -ao alsa,    -vo xv,gl,gl2,x11,null,    -mouse-movements  -input conf=/tmp/FakeInput.conf:file=/home/michal/.config/gambas3/Xt7-Player/.InputPipes/Xt7Input-29112 "/media/0D9B-DD61/HBPVR/TVN-28122011-2138.mts
-10:-57:47:48"

MPlayer2 UNKNOWN (C) 2000-2011 MPlayer Team
Terminal type `unknown' is not defined.
Playing /media/0D9B-DD61/HBPVR/TVN-28122011-2138.mts
-10:-57:47:48.
Exiting... (End of file)
ID_EXIT=EOF

Code: Select all
Unknown key 'CTRL'

mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
File not found: '/media/0D9B-DD61/HBPVR/TVN-28122011-2138.mts
-10:-57:47:48'
Failed to open /media/0D9B-DD
61/HBPVR/TVN-28122011-2138.mts
-10:-57:47:48.


Mplayer2:
Image
eloaders
 
Posts: 26
Joined: Sat Jan 15, 2011 3:45 pm

Re: Xt7-player does not playl mts video format

Postby kokoko3k on Fri Dec 30, 2011 2:15 pm

It won't play because of this:
Code: Select all
File not found: '/media/0D9B-DD61/HBPVR/TVN-28122011-2138.mts
-10:-57:47:48'

Do you have any idea why xt7 thinks the file name contains: "-10:-57:47:48" ?
Maybe you drag'n dropped the file?
If yes, what was the source? Nautilus maybe?
I ask because in recent gambas version something changed in this regard.
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: [NEED INFO] Xt7-player does not playl mts video format

Postby eloaders on Tue Jan 03, 2012 7:51 pm

File address is correct.
if you drag and drop from nautilus, then you can not play.
xt7-player play when I choose with it.
Plays the file. Mts but is not able to determine its position, not the film rewinds.

Image
eloaders
 
Posts: 26
Joined: Sat Jan 15, 2011 3:45 pm

Re: [NEED INFO] Xt7-player does not playl mts video format

Postby kokoko3k on Wed Jan 04, 2012 10:23 am

Ok,
-if you could upload a part of that file somewere, i will try to understand why xt7 cannot seek in it
-i'll try to fix the nautilus problem.

-EDIT-
Drag'n drop issue fixed in the latest revision
-EDIT-
waiting for the sample, you should be able to seek in that file using arrow keys (?)
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm


Re: [OPEN] Xt7-player does not playl mts video format

Postby kokoko3k on Fri Jan 06, 2012 7:17 pm

I tried the sample,
xt7 actually can seek forward and backward with arrow keys and also by the seek bar.
what doesn't work is that the seek bar doesn't go by its own, i'll try to find a way to workaround (this is actually an mplayer bug/feature)
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm

Re: [OPEN] Xt7-player does not playl mts video format

Postby kokoko3k on Mon Jan 09, 2012 6:14 pm

Ok, it was tricky.
mplayer reports a length of 0, while mplayer2 reports a length of about 4minutes.
They're both wrong.
They also don't report any info about the ellapsed time, so the best i could do was to try to guess the error from two conditions:
1- id_length=0 (mplayer1)
2- current time > id_length (mplayer2)
If (1 or 2) then xt7 will ask mplayer the current time position in percent, (yes, mplayer1 and 2 both answers correctly), instead of the absolute time in seconds.

Now you'll still get wrong values in the status bar, but the seek slider will correctly update the position.
Also, with mplayer1 seeking works, while mplayer2 seems not to be able to.
This isn't the first problem i've had with mplayer2 so far, so i suggest you to drop the fork and stay with the original project.

Grab the latest git for the seekbar fix.
User avatar
kokoko3k
Site Admin
 
Posts: 309
Joined: Wed Nov 05, 2008 12:29 pm


Return to Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron

SourceForge.net Logo